Preview 13

This Forum is for Support questions only for Ideal Flight. Please post other questions and suggestions in the General Use & Ideas Forum

Moderators: Steve Waite, SysAdmin

Re: Preview 13

Postby Steve Waite » Mon Aug 19, 2019 4:01 pm

I wanted to put that up today to avoid irritating delays in the menu.

There's a few minor things I'm working on this week, mostly affect the visuals of the program. Some graphic and visual items have altered behaviour slightly due to the way the program now works.
software architect at codelegend.com
equipment: i9-9980Xe 64GB 2xRTX2080ti NVLink 2TB M.2,
i9-9900X 64GB RTX2080ti 2TB M.2, i7-3960X 32GB GTX680 4TB RAID10,
NAS @7TB RAID10
Steve Waite
 
Posts: 4069
Joined: Wed Jun 29, 2011 12:02 am

Re: Preview 13

Postby Orinks » Mon Aug 19, 2019 6:01 pm

Okay, so I completed a flight with P13 last night and noticed something pretty significant. Either the new flight completed sound is so quiet I can't hear it, engine turning off as stated in the changelog for P13, or nothing is playing. I have not changed sound settings between builds. I suppose I'll do a quick return flight to verify, but I definitely put a flight in the records for a profile last night and did not hear a sound when I stopped.

Thanks for the menu fix.
Orinks
 
Posts: 41
Joined: Sat Mar 02, 2019 11:50 pm

Re: Preview 13

Postby Orinks » Mon Aug 19, 2019 7:00 pm

Right, nevermind. I just wasn't sure what that sound was when I heard it last night. So the new flight complete sound does work.
Orinks
 
Posts: 41
Joined: Sat Mar 02, 2019 11:50 pm

Re: Preview 13

Postby Orinks » Mon Aug 19, 2019 7:31 pm

Oi... this problem rears it's ugly head again. Remember the issue we had where we would hear the sound that corresponds to confirming an action in IF. E.G. pressing enter on the homepage menu, and then the menu does not execute with escape for about 30 seconds? Today I got done a test flight to see whether the flight complete sound works and it does. I recorded the flight and pressed okay. I heard that sound like I was supposed to, and then I heard it again when I got to the homepage. Escape brought up the menu, but there was an extreme delay like there was in previous previews. I get it every time I start IF now in this session. I'm not sure which previous preview this was fixed in but this hasn't happened in quite some time.
Orinks
 
Posts: 41
Joined: Sat Mar 02, 2019 11:50 pm

Re: Preview 13

Postby Orinks » Mon Aug 19, 2019 7:38 pm

It fixed itself when I started IF using Narrator. Maybe it's just a matter of restarting the screen reader. Since it hasn't happened in a while I figured I'd mention it, at any rate.
Orinks
 
Posts: 41
Joined: Sat Mar 02, 2019 11:50 pm

Re: Preview 13

Postby Steve Waite » Tue Aug 20, 2019 10:04 am

Yes. It does seem the reader was confused. I have installed an update to NVDA and I thought the performance has improved. I am having a look at what it does. As I mention I always restart NVDA as it seems to have issues when browsers are active. Since IF pops up the browser that could be it.

What you can try is both readers at once, they both say the same thing. If they don't, one reader is confused, generally NVDA.

I also found problems in Narrator and so that is also upgraded this latest windows version.
software architect at codelegend.com
equipment: i9-9980Xe 64GB 2xRTX2080ti NVLink 2TB M.2,
i9-9900X 64GB RTX2080ti 2TB M.2, i7-3960X 32GB GTX680 4TB RAID10,
NAS @7TB RAID10
Steve Waite
 
Posts: 4069
Joined: Wed Jun 29, 2011 12:02 am

Re: Preview 13

Postby Steve Waite » Tue Aug 20, 2019 10:35 am

...With NVDA, this sends out messages when it starts and stops, so IF can use those to check for NVDA present. With Narrator that works in a different way, IF checks for Narrator present when you go back to IF.


With those sound files you can put your own .wav in place of the IF sounds:
"C:\ProgramData\Ideal Flight Professional\Profiles\Sounds"

closeflight.wav is the same volume but a different higher pitched sound of the engines running down.
finishtask.wav is the bell sound for when the flight starts or when a drifting ship has been found.
software architect at codelegend.com
equipment: i9-9980Xe 64GB 2xRTX2080ti NVLink 2TB M.2,
i9-9900X 64GB RTX2080ti 2TB M.2, i7-3960X 32GB GTX680 4TB RAID10,
NAS @7TB RAID10
Steve Waite
 
Posts: 4069
Joined: Wed Jun 29, 2011 12:02 am

Re: Preview 13

Postby Steve Waite » Tue Aug 20, 2019 12:12 pm

The other beeps you hear are from the reader, in certain places in browser or form controls and menus. So it must be what I experience, the reader goes to sleep.

The system can also beep at a particular menu popup, when P3D is running depending on keys pressed. Sometimes I miss press some key and catch a nearby key.

Narrator seems to be more reliable. But I've so far felt that NVDA with the latest update is as good as.
The only sounds IF makes are the bong sound and the engine shutdown. There are click sounds for mouse hovering events.
software architect at codelegend.com
equipment: i9-9980Xe 64GB 2xRTX2080ti NVLink 2TB M.2,
i9-9900X 64GB RTX2080ti 2TB M.2, i7-3960X 32GB GTX680 4TB RAID10,
NAS @7TB RAID10
Steve Waite
 
Posts: 4069
Joined: Wed Jun 29, 2011 12:02 am

Re: Preview 13

Postby Steve Waite » Tue Aug 20, 2019 3:05 pm

If the flight does not close as quickly as expected, Ideal Flight will hang around for it to a certain extent. That would appear as though Ideal Flight is delayed.

It's possible some addon is holding up the sim when it closes. Swap in a stock plane and test close the simulator, or turn off whatever addon might be suspected to see if there's a change.

When you get a change of behaviour with IF, that's when you have to look at the sim. Folk new to Ideal Flight start out by resetting IF which doesn't help.
software architect at codelegend.com
equipment: i9-9980Xe 64GB 2xRTX2080ti NVLink 2TB M.2,
i9-9900X 64GB RTX2080ti 2TB M.2, i7-3960X 32GB GTX680 4TB RAID10,
NAS @7TB RAID10
Steve Waite
 
Posts: 4069
Joined: Wed Jun 29, 2011 12:02 am

Re: Preview 13

Postby Orinks » Wed Aug 21, 2019 2:02 am

The flight closure isn't a problem. It happened after I recorded the flight and pressed okay on the first flight message.

A change and/or restart of screen reader fixed the issue, as I'm zooming around IF now.

Loaded up my stock test profile and did a return flight and all is well now. Hopefully it stay's that way.
Orinks
 
Posts: 41
Joined: Sat Mar 02, 2019 11:50 pm

PreviousNext

Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron