Page 1 of 3

Has anyone experienced IFP crashing during flight gen?

PostPosted: Sun Mar 03, 2019 12:06 am
by Orinks
Hi all,

I've been talking to Steve about a lot of stuff via email, however this is a new one.

Over the past few days, I downloaded IFP and was simply trying out the demo, and it worked good for what I was using it for, just doing random flights to see where they would take me.

However, I decided to buy it yesterday and registered IFP. From that point forward, any flight created within IFP, no matter which method I use, is met with what is apparently the Windows 10 blue screen error.

"Your PC has encountered a problem and needs to restart" error. However, I did absolutely nothing whatsoever to IFP other than purchasing and registering it!

One thing of note is that I do get a package error warning in the flight log in regards to the FS Dreamteam addon manager fsode and something with A2A Accufeel, however these warnings were in the demo and plans generated without issue.

Just curious if anyone else has had this issue because both Steve and I are baffled.

Re: Has anyone experienced IFP crashing during flight gen?

PostPosted: Sun Mar 03, 2019 11:25 am
by Steve Waite
Hi there,

This is a very new error which I am investigating today.

It is possible that IFPro is attempting to read something on the PC and that invokes this 'something' to activate and then perhaps this crashes the system that way. As far as I know IFPro can't actually cause the crash rather this is more likely a driver issue.

I'll report later today.

Re: Has anyone experienced IFP crashing during flight gen?

PostPosted: Sun Mar 03, 2019 6:35 pm
by Steve Waite
OK thanks for getting in touch via the Contact address and sending the report. I see the problem was in relation to the default flights so the problem is resolved quite easily in the end. That was good news.

Regarding the sode xml errors, these are most likely only minor, not all errors affect the use of the scenery. If they don't affect the simulator then not to worry about them.

Best regards

Re: Has anyone experienced IFP crashing during flight gen?

PostPosted: Mon Mar 04, 2019 2:32 am
by Steve Waite
...when we build a flight in unregistered mode, it builds the same flight as it does in registered mode. When registered we have more choices for route types and other things, but otherwise the same or at least 95% of the app runs to create the flight. By registering it simply allows options to come alive in the app. So the chances of IF causing this simply after having registered is very slim (nothings impossible). So I'm wondering if something else was installed on the same day.

A friend of the OP contacted me with the same error, blue screen when building a flight. He sent the memory dump as well. It can be seen that IF has no relation to the fault caused. The report is most likely correct since IF being an exe running, this will be caught fair and square by the crash report, no doubt about it.

What is conspicuous are any reports of problems at all, since hundreds of IFs have gone out with reports of any kind of problems being very rare indeed. IF will however find errors in the system or settings (and reports quite a few) since it invokes things maybe never put to operation in the sim when used simply.

So it could be something that's just appeared in the market maybe and installed around the same time. IF would invoke system resources to obtain information such as Language information about P3D, many things and system items too. Problems in those things can perhaps crash the system, but it is very unlikely that IF itself can cause such a crash. It would more likely be a driver of some kind perhaps. A system thread accessing out of memory was the cause of the crash which is hard to do for an User exe.

Re: Has anyone experienced IFP crashing during flight gen?

PostPosted: Wed Mar 27, 2019 2:00 am
by Steve Waite
IF utilises core operating system features, a lot of different types of resources, reading files and registry data, and obtaining information by running FS code. It reads everything in the simulator, other add-ons don't do it at this scale or gamut. If there's anything under the hood in Windows or the simulator that's even slightly amiss, it's not going to be noticed by adding a plane or airport.

However, IF is likely to run into that error. In the logs, indexing and flight generator, the app will report what it can't do. That is, if it is still running to report it.

In this instance in all the reports the kernel zero thread has stopped and Windows blue screens with a user enforced resource limit error. That doesn't mean the PC user went and set something, but it could.

More likely an app that doesn't work right perhaps mis-set something, and Windows crashes as a driver attempts to create the resource data. Or it is the result of malware attempting to read or infect something.

IF creates 100+ jps and bitmaps and html files and so on during installation and indexes the scenery and planes ok, and builds flights ok.

Then at some point during use of IF, a flight generate is creating six jpgs for the airport maps in the briefing.

During or around that few seconds period in the build process, over half a minute in total, something starts up in the background and hangs the PC.

The only difference with those jpgs is, they are also accessing some addon scenery during their construction.

Could it be malware checking out the sim folder for opportunities? Or some app or driver doing something in response to those jpgs arriving?

I can't see how reading the scenery files does anything. They have all been read-in during indexing without fuss anyway. Although the full dataset had not been extracted from the files.

Well, a kernel error IF is incapable of doing. There's no mention of IF running, or any of it's dlls and exes in the logs. It seems IF was just a passenger when the PC crashed.

Re: Has anyone experienced IFP crashing during flight gen?

PostPosted: Sat Apr 13, 2019 5:08 am
by Steve Waite
Any news?

A third blind pilot with the same issue has contacted after a while of using IF OK they suddenly started to get the crash during building flight. It doesn't happen through no reason.

Nothing in IF error log, only a thread zero kernel crash showing in Windows Administrative log.

Which IF can't cause - unfortunately else I could and certainly would fix it. I can't fix what isn't broke.

I suggest there is something common to the three users which none have been able to advise me on. There's no reports of this elsewhere with thousands of IF users.

Unfortunately the other user re-installed windows and the problem went away so I don't know what caused it.

Re-installing Windows cant fix a problem in IF. You have to look to your system for the problem. If it can be recreated here then I can advise - otherwise is a tangle on these systems with some other problem that is basically out of my control and none of my business. Reinstalling windows fixes windows issues. Drivers and malware cause kernel crashes, not exe apps.

Re: Has anyone experienced IFP crashing during flight gen?

PostPosted: Sat Apr 13, 2019 6:56 am
by Orinks
The reason why I reinstalled is because quite frankly I was getting tired of messing with it when nothing would work. Microsoft told me that it was a developer problem after a Windows repair wouldn't work, So I was stuck. Malware scanner didn't reveal any malware or anything.

Perhaps it's something to do with a component of screen readers? Yet, after a reformat I use NVDA without issue now.

Re: Has anyone experienced IFP crashing during flight gen?

PostPosted: Sun Apr 14, 2019 8:19 am
by Steve Waite
I've found NVDA produces 100% system interrupts on my Win10 but i''ve seen no crashing with it. So I don't think that is it.

Several thousand IF users do not experience the crash, just three blind users that all have boot camp and mac I think, and maybe something common to the three is causing it. IF is just a passenger when the PC dies and the PC reports a thread zero kernel crash. IF simply cannot do that..

Re: Has anyone experienced IFP crashing during flight gen?

PostPosted: Sun Apr 14, 2019 11:52 am
by Orinks
I think Tyler is on the regular native Windows laptop, no Bootcamped Mac. So I don't know.

Re: Has anyone experienced IFP crashing during flight gen?

PostPosted: Sun Apr 14, 2019 12:53 pm
by Steve Waite
So it's not a driver related to boot-camp and apparently can affect any PC.

I don't see a problem here with any add-ons and also it's not a reader related problem.

It has affected three as far as I know. It has appeared only just recently since no updates to IF have been available this year, nothing has changed there.

The problem goes away with a clean Windows install.

The problem does not happen exactly as IF runs, but rather, there is a definite period of a process in parallel with IF during the IF build that is causing the problem. Something that the resources drawn on by IF are invoked and these come into an issue that hangs the PC or even blue screens it with thread zero.

It is not an IF issue, without IF you might not have a clear indication any problems exist in this case. There could be other issues in the PC that don't seem related.

I'm convinced something installed into Windows, possibly a device driver or malware, is monitoring perhaps the docs folder for example and sees files appearing there during the flight build, then acts badly with that invokation.